此前Rabi的几台设备想使用WSL的Mirrored模式时都出现同样的报错:
wsl: 出现了内部错误。
错误代码: CreateInstance/CreateVm/ConfigureNetworking/0x8007054f
wsl: 无法配置网络 (networkingMode Mirrored),回退到 networkingMode None。
网上常说的重启hns服务、重置主机网络之类的方法都不起作用,最后终于找到根因。用pwsh运行这两条命令:
netsh interface ipv4 show dynamicportrange protocol=tcp
netsh interface ipv6 show dynamicportrange protocol=tcp
如果给出的结果是1024-65534都作为tcp出站连接的动态端口,那么WSL就无法成功预留4096个出站端口,导致Mirrored模式无法启动。解决方法是将动态端口范围改回默认值:
netsh interface ipv4 set dynamicportrange protocol=tcp startport=49152 numberofports=16384
netsh interface ipv6 set dynamicportrange protocol=tcp startport=49152 numberofports=16384
重启后就正常了。
文章评论